If you are using Drupal 6 and your host suddenly decides to upgrade their PHP version from 5.2 to 5.3 or 5.4, your site will most likely continue to work, but it will start throwing a bunch of strict warnings, even for non-logged users. The warnings will be similar to these:

Since the errors…

Read More →